WhatsApp is down

Incident Report for Tuvis

Resolved

The issue has been solved by the WhatsApp team.
Posted Feb 28, 2025 - 19:27 UTC

Identified

Posted Feb 28, 2025 - 15:57 UTC
This incident affected: 3rd Party (WhatsApp Web App, WhatsApp Business API).